Discussion:
[Bug 1563055] [NEW] IBM ppc64le MAAS images booting with no network
(too old to reply)
Mike Rushton
2016-03-28 21:14:47 UTC
Permalink
Public bug reported:

The latest daily Xenial image for MAAS seems to lack network
connectivity. Tested with kernel version 4.4.0-15 from the 20160328
image from the daily stream

Attached are logs from the boot sequence as well as the maas deployment
logs.

** Affects: linux (Ubuntu)
Importance: Undecided
Status: Incomplete


** Tags: blocks-hwcert-server

** Attachment added: "maas.log"
https://bugs.launchpad.net/bugs/1563055/+attachment/4615235/+files/maas.log
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1563055

Title:
IBM ppc64le MAAS images booting with no network

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1563055/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs
Mike Rushton
2016-03-28 21:16:48 UTC
Permalink
This post might be inappropriate. Click to display it.
Mike Rushton
2016-03-28 21:17:52 UTC
Permalink
** Attachment added: "clusterd.log"
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1563055/+attachment/4615237/+files/clusterd.log
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1563055

Title:
IBM ppc64le MAAS images booting with no network

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1563055/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs
Mike Rushton
2016-03-28 21:18:59 UTC
Permalink
** Attachment added: "regiond.log"
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1563055/+attachment/4615238/+files/regiond.log

** Summary changed:

- IBM Power8 PPC MAAS images booting with no network
+ IBM ppc64le MAAS images booting with no network
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1563055

Title:
IBM ppc64le MAAS images booting with no network

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1563055/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs
Brad Figg
2016-03-28 21:30:11 UTC
Permalink
This bug is missing log files that will aid in diagnosing the problem.
apport-collect 1563055

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable
to run this command, please add a comment stating that fact and change
the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the
Ubuntu Kernel Team.

** Changed in: linux (Ubuntu)
Status: New => Incomplete
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1563055

Title:
IBM ppc64le MAAS images booting with no network

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1563055/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs
Mike Rushton
2016-03-28 21:42:49 UTC
Permalink
Due to the nature of no network connectivity, We cannot login (curtin
preseed didn't run to setup credentials) or submit logs.

** Changed in: linux (Ubuntu)
Status: Incomplete => Confirmed
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1563055

Title:
IBM ppc64le MAAS images booting with no network

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1563055/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs
Scott Moser
2016-03-29 16:02:45 UTC
Permalink
heres the diagnosis of the failure here:

a.) the powerVM system was successfully booting and installing xenial,
but was failing to bring up networking on the installed system.

b.) curtin had written (as designed) /etc/udev/rules.d/70-persistent-net.rules containing a line like:
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="40:f2:e9:5d:be:68", NAME="eth0"

c.) curtin had written an /etc/network/interfaces file like:
auto eth0
iface eth0 inet dhcp

d.) the cert team had curtin configuration (late_commands) that was writing /etc/network/interfaces in the target with "dhcp on everything". In order to do this, they read the device names from the install environment via /sys/class/net/ . This resulted in /etc/network/interfaces like:
auto enP2p1s0f0
iface enP2p1s0f0 inet dhcp


When the system booted, networking failed to come up because there was no device named 'enP2p1s0f0', as 70-persistent rules named it 'eth0'.
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1563055

Title:
IBM ppc64le MAAS images booting with no network

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1563055/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs
Joseph Salisbury
2016-03-29 18:54:19 UTC
Permalink
** Changed in: linux (Ubuntu)
Importance: Undecided => High

** Changed in: linux (Ubuntu)
Status: Confirmed => Triaged

** Tags added: kernel-da-key
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1563055

Title:
IBM ppc64le MAAS images booting with no network

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1563055/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs
Jeff Lane
2016-06-06 20:31:54 UTC
Permalink
Pretty sure this was resolved by GA... should this be marked invalid or
some other status to reflect this?

** Tags removed: blocks-hwcert-server
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1563055

Title:
IBM ppc64le MAAS images booting with no network

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1563055/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs
Steve Langasek
2017-08-04 15:09:00 UTC
Permalink
** Changed in: linux (Ubuntu)
Status: Triaged => Fix Released
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1563055

Title:
IBM ppc64le MAAS images booting with no network

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1563055/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs
Loading...