Discussion:
[Bug 1761261] [NEW] nouveau/nvidia drivers do not work with display in Bionic on Asus GL703VD Laptop
(too old to reply)
Luke Williams
2018-04-04 18:08:51 UTC
Permalink
Public bug reported:

Tried to install Bionic Desktop on my Asus GL703VD ROG Laptop with
NVIDIA GTX 1050M Video Card (with i915 Intel graphics card when not
using 3D) and the installer does not display. I have tried
nouveau.modeset=0 and nomodeset boot options to no avail. I was able to
finally install Bionic by hooking up the laptop to a projector, but
after a reboot, the laptop display still did not work and I had to set
the account to autologin otherwise I could not loging to the laptop. I
then install openssh-server so that I could ssh into the laptop and I
installed the nvidia-390 drivers from ppa:graphic-drivers/ppa which
installed, but still no local display.

In Artful, I could install with the nouveau.modeset=0 and then
installing the proprietary NVIDIA drivers and everything (except
touchpad, LP: 1738263) worked.

lspci shows the graphics card and NVIDIA card, and lsmod does show that
before NVIDIA drivers install, it is using nouveau, asus_wmi, and i915
for graphcis, and once NVIDIA drivers are install, lsmod only shows i915
and asus_wmi for graphics while nvidia is used for gpu and 3D, but still
no display on the laptop.

lsmod_prenvidia.txt shows the nouveau driver and the /proc/cmdline
lsmod_nvidia.txt shows nvidia drivers installed and the /proc/cmdline
lspci.txt shows the detected hardware
lshw.txt shows the hardware in the laptop.

Please let me know if you need any other information.

Thanks,
Luke

** Affects: xserver-xorg-video-nouveau (Ubuntu)
Importance: Undecided
Status: New


** Tags: asus display gl703vd nouveau nvidia

** Attachment added: "lsmod_prenvidia.txt"
https://bugs.launchpad.net/bugs/1761261/+attachment/5101639/+files/lsmod_prenvidia.txt
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
h
Luke Williams
2018-04-04 18:09:15 UTC
Permalink
** Attachment added: "lshw.txt"
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/1761261/+attachment/5101640/+files/lshw.txt
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com/m
Luke Williams
2018-04-04 18:09:34 UTC
Permalink
** Attachment added: "lsmod_nvidia.txt"
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/1761261/+attachment/5101641/+files/lsmod_nvidia.txt
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://li
Luke Williams
2018-04-04 18:09:50 UTC
Permalink
** Attachment added: "lspci.txt"
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/1761261/+attachment/5101642/+files/lspci.txt
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com
Luke Williams
2018-04-04 18:49:31 UTC
Permalink
** Also affects: nvidia-graphics-drivers-390 (Ubuntu)
Importance: Undecided
Status: New
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.co
Luke Williams
2018-04-05 13:29:23 UTC
Permalink
** Description changed:

Tried to install Bionic Desktop on my Asus GL703VD ROG Laptop with
NVIDIA GTX 1050M Video Card (with i915 Intel graphics card when not
using 3D) and the installer does not display. I have tried
nouveau.modeset=0 and nomodeset boot options to no avail. I was able to
finally install Bionic by hooking up the laptop to a projector, but
after a reboot, the laptop display still did not work and I had to set
- the account to autologin otherwise I could not loging to the laptop. I
+ the account to autologin otherwise I could not login to the laptop. I
then install openssh-server so that I could ssh into the laptop and I
- installed the nvidia-390 drivers from ppa:graphic-drivers/ppa which
+ installed the nvidia-390 drivers from ppa:graphics-drivers/ppa which
installed, but still no local display.

In Artful, I could install with the nouveau.modeset=0 and then
installing the proprietary NVIDIA drivers and everything (except
touchpad, LP: 1738263) worked.

lspci shows the graphics card and NVIDIA card, and lsmod does show that
before NVIDIA drivers install, it is using nouveau, asus_wmi, and i915
for graphcis, and once NVIDIA drivers are install, lsmod only shows i915
and asus_wmi for graphics while nvidia is used for gpu and 3D, but still
no display on the laptop.

lsmod_prenvidia.txt shows the nouveau driver and the /proc/cmdline
lsmod_nvidia.txt shows nvidia drivers installed and the /proc/cmdline
lspci.txt shows the detected hardware
lshw.txt shows the hardware in the laptop.

Please let me know if you need any other information.

Thanks,
Luke
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.u
Luke Williams
2018-04-05 22:02:41 UTC
Permalink
** Changed in: nvidia-graphics-drivers-390 (Ubuntu)
Assignee: (unassigned) => Alberto Milone (albertomilone)

** Changed in: xserver-xorg-video-nouveau (Ubuntu)
Assignee: (unassigned) => Alberto Milone (albertomilone)
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https:/
Davide Villa
2018-04-06 19:23:01 UTC
Permalink
Same problem on my ASUS GL703VD.
I tried the 18.04 beta today starting a live session with the suggested boot option (modprobe.blacklist=nouveau).
I can work using an external monitor connected to the HDMI interface. The laptop display become black during the boot just after few seconds but I can see the boot progress on the external monitor.

The system works fine with Ubuntu 17.10 with the old kernel
4.13.0-38-generic.

I tried the new kernel 4.16 with ubuntu 17.10 from the mainline
repository but the problem is the same: black laptop screen during boot,
external HDMI monitor working.
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinf
Launchpad Bug Tracker
2018-04-06 19:23:57 UTC
Permalink
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: nvidia-graphics-drivers-390 (Ubuntu)
Status: New => Confirmed
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.co
Launchpad Bug Tracker
2018-04-06 19:23:57 UTC
Permalink
Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: xserver-xorg-video-nouveau (Ubuntu)
Status: New => Confirmed
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com
Davide Villa
2018-04-11 18:28:02 UTC
Permalink
Maybe the back-light problem is related to the patch for the Elan1200 touchpad:
https://bugzilla.redhat.com/show_bug.cgi?id=1543769#c69


** Bug watch added: Red Hat Bugzilla #1543769
https://bugzilla.redhat.com/show_bug.cgi?id=1543769
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bug
Alberto Milone
2018-04-12 09:08:40 UTC
Permalink
can you attach your /var/log/gpu-manager.log, please?
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://li
Alberto Milone
2018-04-12 09:18:39 UTC
Permalink
can you attach your /var/log/gpu-manager.log, please?
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://li
Davide Villa
2018-04-12 10:12:32 UTC
Permalink
Here's my log file, as requested, running on the "standard" 17.10 kernel with the latest nvidia driver.
investigating my issue I tried to install the 4.15 and 4.16 series kernel using this version of the nvidia driver.
the monitor works fine in the 4.15.3 version, but in the 4.15.4 and higher the monitor remains off.


** Attachment added: "Log File"
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/1761261/+attachment/5112012/+files/gpu-manager.log
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listin
Luke Williams
2018-04-12 21:11:44 UTC
Permalink
I have noticed the same thing. I am running on 16.04 with the HWE 17.10 kernel and monitor works.
I installed the bionic 4.14.0-17 kernel and I was able to still use the laptop display. I tried the latest Bionic kernel (4.15.0-13) and it does not work.
During testing on another bug (LP:1738263) I tested Artful with the Bionic kernel 4.15.0-10 and everything appeared to be working normally with the exception that DKMS failed to build the NVIDIA modules due to not being compatible with the the header files. However, when you install anything newer, the display fails to stay on past the GRUB menu.
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com/mailman
Luke Williams
2018-04-16 19:48:59 UTC
Permalink
It could be a backlight issue. I tried with the latest daily-build
(April 16, 2018) and I boot up with the nouveau.modeset=0 kernel param
and it shows the splash screen, and then I hear the login sound, and if
I turn off the lights in my office and look closely, I can see the
display, but it looks like the backlight for the screen is not lit. I
tried adjusting the brightness using the FN+F7/F8 (Which adjust
brightness) and they don't work (They don't work on any other
distribution/Release as well. Only things that work are volume control
and Projector options).
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://l
Davide Villa
2018-04-17 08:09:05 UTC
Permalink
Hi all,
I found this bug report: https://bugzilla.redhat.com/show_bug.cgi?id=1543769#c69
and this patch seems to solve the backlight problem (and the ELAN jercky touchpad as well)
I don't know how to compile the kernel with this patch.
maybe someone can build the kernel for me to test on my laptop or let me know how to build myself.


** Patch added: "spth-pinctrl-fix.diff"
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/1761261/+attachment/5119044/+files/spth-pinctrl-fix.diff
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://l
Ubuntu Foundations Team Bug Bot
2018-04-17 08:22:49 UTC
Permalink
The attachment "spth-pinctrl-fix.diff" seems to be a patch. If it
isn't, please remove the "patch" flag from the attachment, remove the
"patch" tag, and if you are a member of the ~ubuntu-reviewers,
unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by
~brian-murray, for any issues please contact him.]

** Tags added: patch
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo
Luke Williams
2018-04-23 17:08:08 UTC
Permalink
So I patched the 4.15.0-15-generic kernel from kernel.ubuntu.com with
the supplied patch and then intstalled the kernel on my 16.04 xenail
laptop and everything works as it should. The display came up, the touch
pad is responsive and working normally. I have enclosed my dumps of
lswh, lspci, lsmod and my cmdline output.

How I installed this:
I build a bionic container on my laptop:
lxc launch ubuntu-daily:bionic kernel
lxc file push spth-pinctrl-fix.diff kernel/root/
lxc exec kernel bash
apt update && apt upgrade -y
apt build-dep linux-image-`uname -r`
apt install fakeroot
git clone git://kernel.ubuntu.com/ubuntu/ubuntu-bionic.git
cd ubuntu-bionic
cp ../spth-pinctrl-fix.diff .
patch -p1 < spth-pintctrl-fix.diff
fakeroot debian/rules clean
fakeroot debian/rules binary-headers binary-generic binary-perarch

After the build and the output of the deb files:
exit
mkdir ~/kernel-test
cd ~/kernel-test
lxc file pull kernel/root/linux-image-4.15.0-15-generic_4.15.0-15.16_amd64.deb .
lxc file pull kernel/root/linux-image-extra-4.15.0-15-generic_4.15.0-15.16_amd64.deb .
lxc file pull kernel/root/linux-headers-4.15.0-15_4.15.0-15.16_all.deb .
lxc file pull kernel/root/linux-headers-4.15.0-15-generic_4.15.0-15.16_amd64.deb .

Also, the linux-headers-4.15.0-15 deb depends on libssl1.1, which is
default in Bionic, but not in Xenial, so I had to download that deb file
from here: https://packages.ubuntu.com/bionic/libssl1.1

And then I just used dpkg -i to install the files and reboot the laptop
and it started up properly.

While the laptop display works and the touchpad is responsive and works
properly. there are still issues with the FN+F7/F8 brightness controls,
and the other FN options that should work out of the box, but at least
the display works with the 4.15.0-15 kernel


** Attachment added: "logs.tar.gz"
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+attachment/5125965/+files/logs.tar.gz
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubun
Luke Williams
2018-04-30 19:50:26 UTC
Permalink
I tried testing with the latest RC build of the 4.17 kernel from kernel.org (Torvald's GIT) and built the kernel following the instructions here [1].
After installing the kernel and headers, it looks like it regressed and the display did not work (backlight) and I could not switch terminals. I was able to reboot my laptop and switch the the previous kernel. My next test will be with the patches and see what happens.
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/u
Luke Williams
2018-04-30 20:11:21 UTC
Permalink
[1] https://wiki.ubuntu.com/KernelTeam/GitKernelBuild
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
https://li
Luke Williams
2018-04-30 20:55:42 UTC
Permalink
Trackpad and Graphics work with the spth-pincntrl-fix.diff patch on the
4.17 kernel, however, the wifi card does not work, and if you close the
lid or it goes to hibernate, the system becomes unresponsive.

I removed this kernel and am working again on the 4.15.0-20 kernel with
the patch.
--
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/1761261

Title:
nouveau/nvidia drivers do not work with display in Bionic on Asus
GL703VD Laptop

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1761261/+subscriptions
--
ubuntu-bugs mailing list
ubuntu-***@lists.ubuntu.com
ht
Loading...